Eraser is erasing multiple layers

I am working with digital watercolors, and have created multiple layers to add detail to my painting. When I use the eraser on a selected layer, it also erases from the layers below. Even when I lock the lower layers, they are still being erased. Am I missing a setting somewhere? This didn't happen in previous versions of the software.

  • Hi DM,

    It sounds like it ought to be a setting but I can't find anything like it on my initial search....

    I'll try and get it to do the same on my machine. What brushes are you using? Is it the regular eraser?

    It sounds frustrating...

  • Ah!

    Just another thought... at the top of your layers palette is "Preserve Transparency" selected?

    If it IS then anything you erase will leave a white area in the layer where the paint had been, masking out the layers behind it.

    Make the current layer invisible to see if the other layers still exist behind it.....

  • Second thoughts, the transparency thing wouldn't affect it if the layers are gel layers with invisible whites, which they should be with digital watercolour.

    I'm stumped.

  • it's a bug.

    try resetting the eraser tool first,

    if that doesn't help, back up your custom assets (brushes, shortcuts, papers, you name it - anything you've custom created) and reset painter (hold "shift" while launching and follow up with screen instructions.)

    to my knowledge there're no eraser variants explicitly designed to affect multiple layers in painter, and that behavior should not appear by itself.

    you might want to repost this to facebook.com/corelpainter if you use FB just so the bug report gets passed onto painter development team, but the digital watercolor component in painter has been neglected for close to a decade anyway (I think they finally gave up on updating it around painter 11), so don't expect much.