Corel Painter 9: My eraser tool creates a new Think Paint Layer without erasing

So I ran into this problem where any time i try to use my eraser tool (in soft mode only) it creates a new "Thick Paint layer" that is not default and that is locked on ignore, as soon as i start to use it regardless of the type of layer im trying to erase in. Which proceeds to obviously not erasing anything at all. 

I've tried reseting all the paint brushes. I've tried reseting the software. I've tried looking to see if I changed the erasing settings and everything is as default. So I can't figure out why it's doing it.

To give some more background, this glitch started happening after i started using some thick paint brushes, however, on that specific painting, even now when i try and go and edit layers that are thick paint as well, the eraser tool still creates a new separate layer, and again, doesn't erase anything. 

Yes, other erasing brushes work, but i find it inconvenient not being able to quick key the eraser tool when i need a soft erase for my paintings. I've messed with all sorts of layer setting s and brush settings and nothing seems to work. Anyone?