Tos becomes ts

I have painter 12 on windows 10. Has worked great for years. That is until  a win 10 update crashed my hard drive and the tech guy was forced to format and do a fresh install.  Now I have to find all the install disc / links for all  my old  programs,  some no longer  available. And the serials. Who keeps a serial number for something that has worked for a decade. Now its time for painter 12. Install,  check.  Serial number,  check.  Hit icon, check.  The warm up screen comes with what should be the  tos screen, but it is empty. As in blank. No square you can check, nothing. Just an agree button that you can't click until you check that little square. I've tried both the CD and the link from corel, different  versions, any variations I  could think of.all the same  result. I have no desire to be forced to pay for an upgrade a.i can't afford it, and b.I don't want it. Please help!

  • Hi NewPicasso,

    Ugh, sounds frustrating. I've got a couple ideas that might get you going worth a shot...

    1. Try hitting "ESC". This might simply close and prevent Painter from launching but you never know.

    2. If that doesn't work, try using the mouse wheel to zoom the content out so you can see the controls properly

    3. If that doesn't work, you can try hitting tab, to hopefully get to some controls that allow you to proceed.

    By the way, is it a "terms of service" or registration screen? What is your default browser? I'm wondering if somehow the older registration screen doesn't render properly on Microsoft Edge, so maybe installing a legacy browser could help???

    Just some ideas to keep you going with Painter 12...