Unable to save file

Hello. New here.  I have a Windows 10 laptop.  I installed my old Painter 11 and all was fine but I couldn't save my work.  I kept getting a popup that "the file.....001.tmp could not be created."  I assumed maybe my old software wouldn't work with Windows 10, as I have encountered that problem with other software. 

So I purchased Painter Essentials 6.  The same thing is happening!  

I've read a lot about this being an issue with Corel. I have submitted a support ticket to Corel and sent my info to them.  Seems for some programs the temp files fill up, so I followed instructions and deleted all of them, hopefully.  Still no luck.  I uninstalled the old software, reinstalled the Essentials, restarted my computer, and nothing.  

Anyone else having this issue?

  • Dang, I DID have this trouble  a few years back but I just can't remember what the problem was.. so sorry!

    Have you tried saving the file under another name? Another file format? Downsizing the file (collapsing layers, perhaps?)

    Could be an issue with the way the software is using memory... I'll hunt thru google and see what else comes up.

  • Looks like the isssue had ocurred with Painter 9.5. The suggested answer was to save as a psd to wipe any rif specific data which may have corrupted:

    painterfactory.com/.../file-cannot-be-created-warning-when-saving-files 

  • I recall my issue was actually some sort of corruption, whether with the spot on the disk the file was being saved or what I don't recall. If the absolute worst happens (and this is a horrible way to rescue art from the ashes... definitely a last resort) take a screen shot of the image before shutting down the software and trace it to try and reproduce the hard efforts that have just gone down the sink. I recall Painter 11 wasn't all that stable and I lost a lot of drawings myself. (luckily the 2019 version is a ton more stable)

    What does Essentials cost these days? What are the specs of your laptop?

    I only trialled 2011 if I remember aright, skipping from 10 to 12 because 11's stability improvements weren't significant enough , but in those days I worked on a laptop (early Tablet PC). I wondered what the ideal hardware and software environment was for Painter at the time,  I'm certain it worked well for some and less so for others.

    I recall 11 may not have had multi core support yet?

    AH! Another thing to try is this: Put your original file in the recycle bin then try saving. OR save the new file to desktop. Anywhere on the drive apart from the current directory.

    I remember observing something like this: painter creates the temp file, renames the existing file so it replaces the bak file and and then replaces the existing file with the tmp file.

    If you ever come across a tmp file you can often rename it .riff and it works just fine.

    Also make sure the drive is defragged/optimised, I recall THAT playing havoc: a fragmented swapfile.

    I hope something in there is helpful!

    Best luck,

    -Brendoon

  • There's one more (large) reply but I accidentally reported myself as spam when I was editing it! The buttons are adjacent...

    It may reappear tomorrow.

    BUT, in the meantime try saving the file to desktop or anywhere on the disc apart from the original folder. If all else fails, save a screenshot of the art before you close the software. This is a terrible way to go, but you then have a reference handy if you have to rebuild it.

  • Hi again Marsha!

    I've just remembered something from that lost post which may be of value... check your harddrive isn't fragmented, in the past when I've had a lot of errors, crashes and whatnot that a smooth-running harddrive makes a lot of difference.